re = /\s+|(?<!\s)(?=-)/m
str = '19 20 22 -1 -3-4-10 -7 2 10'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result