import re
regex = re.compile(r"\s+|(?<!\s)(?=-)", flags=re.MULTILINE)
test_str = "19 20 22 -1 -3-4-10 -7 2 10"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)