$re = '~\s+|(?<!\s)(?=-)~m';
$str = '19 20 22 -1 -3-4-10 -7 2 10';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;