import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^function\\s+((?!global[:]|local[:]|script[:]|private[:])[\\w-]+)";
final String string = "function Get-Content\n"
+ "function Get-Content {\n"
+ "function Get-Content () {\n"
+ "function Get-Content-Thing\n"
+ "function Get-Content ($path) {\n"
+ " function Get-Content\n"
+ "function Get-Content\n"
+ "function Get-Content\n"
+ "function Content\n"
+ "function Global-Content\n"
+ "function local-Content\n"
+ "function Script-Content\n"
+ "function private-Content\n"
+ "function global:Get-Content\n"
+ "function local:Get-Content\n"
+ "function script:Get-Content\n"
+ "function private:Get-Content";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}