$re = '/^function\s+((?!global[:]|local[:]|script[:]|private[:])[\w-]+)/mi';
$str = 'function Get-Content
function Get-Content {
function Get-Content () {
function Get-Content-Thing
function Get-Content ($path) {
function Get-Content
function Get-Content
function Get-Content
function Content
function Global-Content
function local-Content
function Script-Content
function private-Content
function global:Get-Content
function local:Get-Content
function script:Get-Content
function private:Get-Content';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);