use strict;
my $str = 'function Get-Content
function Get-Content {
function Get-Content () {
function Get-Content-Thing
function Get-Content ($path) {
function Get-Content
function Get-Content
function Get-Content
function Content
function Global-Content
function local-Content
function Script-Content
function private-Content
function global:Get-Content
function local:Get-Content
function script:Get-Content
function private:Get-Content';
my $regex = qr/^function\s+((?!global[:]|local[:]|script[:]|private[:])[\w-]+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}