# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^function\s+((?!global[:]|local[:]|script[:]|private[:])[\w-]+)"
test_str = ("function Get-Content\n"
"function Get-Content {\n"
"function Get-Content () {\n"
"function Get-Content-Thing\n"
"function Get-Content ($path) {\n"
" function Get-Content\n"
"function Get-Content\n"
"function Get-Content\n"
"function Content\n"
"function Global-Content\n"
"function local-Content\n"
"function Script-Content\n"
"function private-Content\n"
"function global:Get-Content\n"
"function local:Get-Content\n"
"function script:Get-Content\n"
"function private:Get-Content")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.