import Foundation
let pattern = #"^function\s+((?!global[:]|local[:]|script[:]|private[:])[\w-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
function Get-Content
function Get-Content {
function Get-Content () {
function Get-Content-Thing
function Get-Content ($path) {
function Get-Content
function Get-Content
function Get-Content
function Content
function Global-Content
function local-Content
function Script-Content
function private-Content
function global:Get-Content
function local:Get-Content
function script:Get-Content
function private:Get-Content
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)