const regex = /^function\s+((?!global[:]|local[:]|script[:]|private[:])[\w-]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^function\\s+((?!global[:]|local[:]|script[:]|private[:])[\\w-]+)', 'gmi')
const str = `function Get-Content
function Get-Content {
function Get-Content () {
function Get-Content-Thing
function Get-Content (\$path) {
function Get-Content
function Get-Content
function Get-Content
function Content
function Global-Content
function local-Content
function Script-Content
function private-Content
function global:Get-Content
function local:Get-Content
function script:Get-Content
function private:Get-Content`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}