#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(?!-0(\.0+)?(e|$))-?(0|[1-9]\d*)(\.\d+)?(e-?(0|[1-9]\d*))?$"
Local $sString = "0.00513462" & @CRLF & _
"2.3443E-4" & @CRLF & _
"0.00634808" & @CRLF & _
"3.6294E-4" & @CRLF & _
"0.00734615" & @CRLF & _
"6.2741E-4" & @CRLF & _
"0.00850962" & @CRLF & _
"9.9755E-4" & @CRLF & _
"0.01004615" & @CRLF & _
"0.00164486"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")