import re
regex = re.compile(r"^(?!-0(\.0+)?(e|$))-?(0|[1-9]\d*)(\.\d+)?(e-?(0|[1-9]\d*))?$", flags=re.IGNORECASE)
test_str = ("0.00513462\n"
"2.3443E-4\n"
"0.00634808\n"
"3.6294E-4\n"
"0.00734615\n"
"6.2741E-4\n"
"0.00850962\n"
"9.9755E-4\n"
"0.01004615\n"
"0.00164486")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")