re = /^(?!-0(\.0+)?(e|$))-?(0|[1-9]\d*)(\.\d+)?(e-?(0|[1-9]\d*))?$/i
str = '0.00513462
2.3443E-4
0.00634808
3.6294E-4
0.00734615
6.2741E-4
0.00850962
9.9755E-4
0.01004615
0.00164486'
# Print the match result
str.match(re) do |match|
puts match.to_s
end