$re = '/^(?!-0(\.0+)?(e|$))-?(0|[1-9]\d*)(\.\d+)?(e-?(0|[1-9]\d*))?$/i';
$str = '0.00513462
2.3443E-4
0.00634808
3.6294E-4
0.00734615
6.2741E-4
0.00850962
9.9755E-4
0.01004615
0.00164486';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);