const regex = /^(?!-0(\.0+)?(e|$))-?(0|[1-9]\d*)(\.\d+)?(e-?(0|[1-9]\d*))?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!-0(\\.0+)?(e|$))-?(0|[1-9]\\d*)(\\.\\d+)?(e-?(0|[1-9]\\d*))?$', 'i')
const str = `0.00513462
2.3443E-4
0.00634808
3.6294E-4
0.00734615
6.2741E-4
0.00850962
9.9755E-4
0.01004615
0.00164486`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}