import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!-0(\\.0+)?(e|$))-?(0|[1-9]\\d*)(\\.\\d+)?(e-?(0|[1-9]\\d*))?$";
final String string = "0.00513462\n"
+ "2.3443E-4\n"
+ "0.00634808\n"
+ "3.6294E-4\n"
+ "0.00734615\n"
+ "6.2741E-4\n"
+ "0.00850962\n"
+ "9.9755E-4\n"
+ "0.01004615\n"
+ "0.00164486";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}