using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/example\.com\/foo((\/[\w]+\b)?[^\/]|\/[^\w])";
string input = @"http://example.com/foo
http://example.com/foo/
http://example.com/foo/apple
http://example.com/foo/bear
http://example.com/foo/cake
http://example.com/baa/apple
http://example.com/foo/apple/cake/bar/1
http://example.com/foo/bear/camel/bar/2
http://example.com/foo/bear/cake/bar/two
http://example.com/foo/bear/camel/tar/2
http://example.com/foo/bear/camel
http://example.com/foo/bear/camel/
http://example.com/foo/bear/camel/tar/2/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}