// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http:\/\/example\.com\/foo((\/[\w]+\b)?[^\/]|\/[^\w])").unwrap();
let string = "http://example.com/foo
http://example.com/foo/
http://example.com/foo/apple
http://example.com/foo/bear
http://example.com/foo/cake
http://example.com/baa/apple
http://example.com/foo/apple/cake/bar/1
http://example.com/foo/bear/camel/bar/2
http://example.com/foo/bear/cake/bar/two
http://example.com/foo/bear/camel/tar/2
http://example.com/foo/bear/camel
http://example.com/foo/bear/camel/
http://example.com/foo/bear/camel/tar/2/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}