import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/example\\.com\\/foo((\\/[\\w]+\\b)?[^\\/]|\\/[^\\w])";
final String string = "http://example.com/foo\n"
+ "http://example.com/foo/\n"
+ "http://example.com/foo/apple\n"
+ "http://example.com/foo/bear\n"
+ "http://example.com/foo/cake\n\n"
+ "http://example.com/baa/apple\n"
+ "http://example.com/foo/apple/cake/bar/1\n"
+ "http://example.com/foo/bear/camel/bar/2\n\n"
+ "http://example.com/foo/bear/cake/bar/two\n"
+ "http://example.com/foo/bear/camel/tar/2\n"
+ "http://example.com/foo/bear/camel\n"
+ "http://example.com/foo/bear/camel/\n"
+ "http://example.com/foo/bear/camel/tar/2/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}