const regex = /http:\/\/example\.com\/foo((\/[\w]+\b)?[^\/]|\/[^\w])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/example\\.com\\\/foo((\\\/[\\w]+\\b)?[^\\\/]|\\\/[^\\w])', 'g')
const str = `http://example.com/foo
http://example.com/foo/
http://example.com/foo/apple
http://example.com/foo/bear
http://example.com/foo/cake
http://example.com/baa/apple
http://example.com/foo/apple/cake/bar/1
http://example.com/foo/bear/camel/bar/2
http://example.com/foo/bear/cake/bar/two
http://example.com/foo/bear/camel/tar/2
http://example.com/foo/bear/camel
http://example.com/foo/bear/camel/
http://example.com/foo/bear/camel/tar/2/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}