using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@[a-zA-Z0-9]+\s?[a-zA-Z0-9]*$";
string substitution = @"";
string input = @"@foo bar
@fo12 o";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}