// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^@[a-zA-Z0-9]+\s?[a-zA-Z0-9]*$").unwrap();
let string = "@foo bar
@fo12 o";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}