re = /^@[a-zA-Z0-9]+\s?[a-zA-Z0-9]*$/m
str = '@foo bar
@fo12 o'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result