$re = '/^@[a-zA-Z0-9]+\s?[a-zA-Z0-9]*$/m';
$str = '@foo bar
@fo12 o';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;