using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Address: )(.+?)(?=Application Received: |$)";
string input = @"EEE gof tune Avi Barides Company: Amdocs International Inc. Address: 81 descanso drive forns: fdf 10 cade for the email: test@test.com Address: mockup 10 USA Application Received: 3/4/2020 Source: mentor";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}