$re = '/(?<=Address: )(.+?)(?=Application Received: |$)/m';
$str = 'EEE gof tune Avi Barides Company: Amdocs International Inc. Address: 81 descanso drive forns: fdf 10 cade for the email: test@test.com Address: mockup 10 USA Application Received: 3/4/2020 Source: mentor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);