const regex = /(?<=Address: )(.+?)(?=Application Received: |$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Address: )(.+?)(?=Application Received: |$)', 'gm')
const str = `EEE gof tune Avi Barides Company: Amdocs International Inc. Address: 81 descanso drive forns: fdf 10 cade for the email: test@test.com Address: mockup 10 USA Application Received: 3/4/2020 Source: mentor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}