import re
regex = re.compile(r"(?<=Address: )(.+?)(?=Application Received: |$)", flags=re.MULTILINE)
test_str = "EEE gof tune Avi Barides Company: Amdocs International Inc. Address: 81 descanso drive forns: fdf 10 cade for the email: test@test.com Address: mockup 10 USA Application Received: 3/4/2020 Source: mentor"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")