re = /(?<=Address: )(.+?)(?=Application Received: |$)/m
str = 'EEE gof tune Avi Barides Company: Amdocs International Inc. Address: 81 descanso drive forns: fdf 10 cade for the email: test@test.com Address: mockup 10 USA Application Received: 3/4/2020 Source: mentor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end