import Foundation
let pattern = #"(?<=Address: )(.+?)(?=Application Received: |$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"EEE gof tune Avi Barides Company: Amdocs International Inc. Address: 81 descanso drive forns: fdf 10 cade for the email: test@test.com Address: mockup 10 USA Application Received: 3/4/2020 Source: mentor"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)