# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!^)(?<!,)"(?!$|,)//gim;t' <<< "\"3610212505\",\"3610212505\",\"Jack is 6'2\" tall\""