using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^)(?<!,)""(?!$|,)";
string substitution = @"";
string input = @"""3610212505"",""3610212505"",""Jack is 6'2"" tall""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}