use strict;
my $str = '"3610212505","3610212505","Jack is 6\'2" tall"';
my $regex = qr/(?<!^)(?<!,)"(?!$|,)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";