re = /(?<!^)(?<!,)"(?!$|,)/im
str = '"3610212505","3610212505","Jack is 6\'2" tall"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result