$re = '/(?<!^)(?<!,)"(?!$|,)/im';
$str = '"3610212505","3610212505","Jack is 6\'2" tall"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;