const regex = /(?<!^)(?<!,)"(?!$|,)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^)(?<!,)"(?!$|,)', 'gim')
const str = `"3610212505","3610212505","Jack is 6'2" tall"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);