# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.+lat\\":\\"(.+)\\",\\"lng\\":\\"(.+)\\",\\"city\\":\\"(.+)\\",\\"poi.+date\\":\\"(.+)\\",\\"country.+title\\":\\"(.+)\\"\}/$1\t$2\t$3\t$4\t$5/gm;t' <<< "\\"Locations\\":[{\\"lat\\":\\"37.77160263061523\\",\\"lng\\":\\"-120.85061645507812\\",\\"city\\":\\"Oakdale\\",\\"poi\\":\\"\\",\\"pindata_id\\":\\"194395\\"}]},{\\"User\\":{\\"id\\":\\"<censored>\\",\\"username\\":\\"<censored>\\"},\\"Pindata\\":{\\"id\\":\\"194739\\",\\"date\\":\\"2018-05-18\\",\\"country\\":\\"US\\",\\"title\\":\\"Let's go!\\"}"