# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+lat\\\":\\\"(.+)\\\",\\\"lng\\\":\\\"(.+)\\\",\\\"city\\\":\\\"(.+)\\\",\\\"poi.+date\\\":\\\"(.+)\\\",\\\"country.+title\\\":\\\"(.+)\\\"\}"
test_str = "\\\"Locations\\\":[{\\\"lat\\\":\\\"37.77160263061523\\\",\\\"lng\\\":\\\"-120.85061645507812\\\",\\\"city\\\":\\\"Oakdale\\\",\\\"poi\\\":\\\"\\\",\\\"pindata_id\\\":\\\"194395\\\"}]},{\\\"User\\\":{\\\"id\\\":\\\"<censored>\\\",\\\"username\\\":\\\"<censored>\\\"},\\\"Pindata\\\":{\\\"id\\\":\\\"194739\\\",\\\"date\\\":\\\"2018-05-18\\\",\\\"country\\\":\\\"US\\\",\\\"title\\\":\\\"Let's go!\\\"}"
subst = "$1\\t$2\\t$3\\t$4\\t$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.