using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+lat\\"":\\""(.+)\\"",\\""lng\\"":\\""(.+)\\"",\\""city\\"":\\""(.+)\\"",\\""poi.+date\\"":\\""(.+)\\"",\\""country.+title\\"":\\""(.+)\\""\}";
string substitution = @"$1\t$2\t$3\t$4\t$5";
string input = @"\""Locations\"":[{\""lat\"":\""37.77160263061523\"",\""lng\"":\""-120.85061645507812\"",\""city\"":\""Oakdale\"",\""poi\"":\""\"",\""pindata_id\"":\""194395\""}]},{\""User\"":{\""id\"":\""<censored>\"",\""username\"":\""<censored>\""},\""Pindata\"":{\""id\"":\""194739\"",\""date\"":\""2018-05-18\"",\""country\"":\""US\"",\""title\"":\""Let's go!\""}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}