// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m).+lat\\":\\"(.+)\\",\\"lng\\":\\"(.+)\\",\\"city\\":\\"(.+)\\",\\"poi.+date\\":\\"(.+)\\",\\"country.+title\\":\\"(.+)\\"\}"#).unwrap();
let string = "\\\"Locations\\\":[{\\\"lat\\\":\\\"37.77160263061523\\\",\\\"lng\\\":\\\"-120.85061645507812\\\",\\\"city\\\":\\\"Oakdale\\\",\\\"poi\\\":\\\"\\\",\\\"pindata_id\\\":\\\"194395\\\"}]},{\\\"User\\\":{\\\"id\\\":\\\"<censored>\\\",\\\"username\\\":\\\"<censored>\\\"},\\\"Pindata\\\":{\\\"id\\\":\\\"194739\\\",\\\"date\\\":\\\"2018-05-18\\\",\\\"country\\\":\\\"US\\\",\\\"title\\\":\\\"Let's go!\\\"}";
let substitution = "$1\\t$2\\t$3\\t$4\\t$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}