import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+lat\\\\\":\\\\\"(.+)\\\\\",\\\\\"lng\\\\\":\\\\\"(.+)\\\\\",\\\\\"city\\\\\":\\\\\"(.+)\\\\\",\\\\\"poi.+date\\\\\":\\\\\"(.+)\\\\\",\\\\\"country.+title\\\\\":\\\\\"(.+)\\\\\"\\}";
final String string = "\\\"Locations\\\":[{\\\"lat\\\":\\\"37.77160263061523\\\",\\\"lng\\\":\\\"-120.85061645507812\\\",\\\"city\\\":\\\"Oakdale\\\",\\\"poi\\\":\\\"\\\",\\\"pindata_id\\\":\\\"194395\\\"}]},{\\\"User\\\":{\\\"id\\\":\\\"<censored>\\\",\\\"username\\\":\\\"<censored>\\\"},\\\"Pindata\\\":{\\\"id\\\":\\\"194739\\\",\\\"date\\\":\\\"2018-05-18\\\",\\\"country\\\":\\\"US\\\",\\\"title\\\":\\\"Let's go!\\\"}";
final String subst = "$1\\t$2\\t$3\\t$4\\t$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}