# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(?:^|[^\\])(?:\\\\)*)(([`'"])(.*?(?:[^\\](\\\\)*|$)(\2|$)))/<span>$1<\/span>/g;t' <<< "\"I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge.\"\n\"That is my opinion too,\" said Ned Land, coolly. \"Let us wait for night.\""