#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)(?:(params\s*=\s*\{.*?})(.*))?$"
Local $sString = "@RequestMapping(value = "/breezeQuery", params = {"path", "contentName"}, method = RequestMethod.GET)" & @CRLF & _
"@RequestMapping(value = "/breezeQuery", method = RequestMethod.GET)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")