package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(?:(params\s*=\s*\{.*?})(.*))?$`)
var str = `@RequestMapping(value = "/breezeQuery", params = {"path", "contentName"}, method = RequestMethod.GET)
@RequestMapping(value = "/breezeQuery", method = RequestMethod.GET)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}