re = /^(.*?)(?:(params\s*=\s*\{.*?})(.*))?$/m
str = '@RequestMapping(value = "/breezeQuery", params = {"path", "contentName"}, method = RequestMethod.GET)
@RequestMapping(value = "/breezeQuery", method = RequestMethod.GET)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end