const regex = /^(.*?)(?:(params\s*=\s*\{.*?})(.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(?:(params\\s*=\\s*\\{.*?})(.*))?$', 'gm')
const str = `@RequestMapping(value = "/breezeQuery", params = {"path", "contentName"}, method = RequestMethod.GET)
@RequestMapping(value = "/breezeQuery", method = RequestMethod.GET)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}