$re = '/^(.*?)(?:(params\s*=\s*\{.*?})(.*))?$/m';
$str = '@RequestMapping(value = "/breezeQuery", params = {"path", "contentName"}, method = RequestMethod.GET)
@RequestMapping(value = "/breezeQuery", method = RequestMethod.GET)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);