using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)(?:(params\s*=\s*\{.*?})(.*))?$";
string input = @"@RequestMapping(value = ""/breezeQuery"", params = {""path"", ""contentName""}, method = RequestMethod.GET)
@RequestMapping(value = ""/breezeQuery"", method = RequestMethod.GET)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}