import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Subject\\:)(?:[\\r\\n]{2})(?<Subject>.+)";
final String string = "Subject:\n\n"
+ "Object reference not set to an instance of an object.\n\n"
+ "Created On (UTC): 6/26/2017 3:03:03 PM";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}