// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:Subject\:)(?:[\r\n]{2})(?<Subject>.+)").unwrap();
let string = "Subject:
Object reference not set to an instance of an object.
Created On (UTC): 6/26/2017 3:03:03 PM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}