$re = '/(?:Subject\:)(?:[\r\n]{2})(?<Subject>.+)/';
$str = 'Subject:
Object reference not set to an instance of an object.
Created On (UTC): 6/26/2017 3:03:03 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);